Java upgrade to Windows operating systems

November 13, 2019

The following information applies only to those computers running Windows operating systems.

Summary

Yale ITS began delivering an updated version of Java, automatically, in batches, to ITS supported computers on Wednesday, November 13. This process will continue until all ITS managed computers are updated.

IMPORTANT: The Java Runtime Environment (JRE) update package is based on version 1.8.0_212 and has been modified for use at Yale. Therefore, downloading Java from the Java website, or anywhere else, will not provide the correct configurations for Yale’s environment.

Details

Many web-based applications and services (Yale and non-Yale business applications, games, websites, etc.) rely on Java technology to run. The upgraded Yale-specific Java software is necessary to ensure computers currently running Java have a secure and compatible version, allowing users to securely access MyTime/Kronos, and other applications that rely on Java.

How do I get the correct version of Java?

  • Yale-managed computers (including Managed Workstations) - The upgrade will be automatically distributed to your computer with approved, pre-configured settings and will roll-out to departments in phases, starting Wednesday, November 13.
  • All other Windows computers (not managed by ITS) - Visit the ITS software library to install JRE version 1.8.0_212 or contact your local support provider. Avoid downloading Java from the Java website, or anywhere else, since it will not provide the correct configurations for Yale’s environment.

What can I expect after the upgrade?

You may experience delays the first time you access MyTime after the upgrade; this behavior is normal.

You may receive security pop-up window(s) the first time you access MyTime/Kronos or other Java-dependent applications after the upgrade. Below are some of the most common warnings, and guidance for each:

A website wants to open web content using this program (Java/JRE) on your computer.

  1. Check the box: Do not show me the warning for this program again
  2. Select Allow

Do you want to run this application (Java/JRE)?

  1. Check the box: Do not show this again for this app
  2. Select the Run button

Do you want to run this ActiveX control?

  1. Check the box: Do not show this again for this app
  2. Select the Run button

An application would like access to an old version of Java.

  1. Choose Run with the latest version on your system
  2. Select the Continue button to dismiss the warning in the future

Your Java version is out of date.

  • Select Later, then select Continue
  • You will be reminded to update again later.

NOTE: Some web browsers do not run Java applets (e.g., Chrome, newer version of Firefox, etc.) and, therefore, they will not run the full version of MyTime (or other Java-dependent applications.) In these cases, we recommend that you run MyTimeLite in the browser of your choice, or, if necessary, select Internet Explorer to run the full MyTime.

Need help?
If you need support for an unmanaged computer or you are experiencing issues with Java, contact the ITS Help Desk or your local support provider.